HOME > News & Topics > If you apply the Java update (6u45 or newer), the CDE will fail to work.
News & Topics
May 9, 2013

If you apply the Java update (6u45 or newer), the CDE will fail to work.

If you apply the Java update (6u45 or newer), the CDE will fail to work.

Reason:
Changes made to Runtime.exec break the connection between Eclipse and Curl, which is needed by the CDE.
For details of the changes in Java within this update, see the following link from Oracle:
http://www.oracle.com/technetwork/java/javase/6u45-relnotes-1932876.html

Workaround:
Either of the following two workarounds will address the problem.

1. Uninstall Curl IDE/RTE completely, and then reinstall them to a path that does not contain any spaces.
Correct: C:\Curl
Correct: C:\Application\Curl
Incorrect: C:\Program Files\Curl Corporation
Incorrect: C:\Curl Corporation
2. Do not apply the Java' update.